using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[shortcode ([^ ]*)(?:[ ]?([^ ]*)=""([^""]*)"")*\]";
string input = @"[shortcode contact param1=""test 2"" param2=""test1""]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}