re = /\[shortcode ([^ ]*)(?:[ ]?([^ ]*)="([^"]*)")*\]/m
str = '[shortcode contact param1="test 2" param2="test1"]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end