$re = '/\[shortcode ([^ ]*)(?:[ ]?([^ ]*)="([^"]*)")*\]/m';
$str = '[shortcode contact param1="test 2" param2="test1"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);