using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"The (?:first|second) section of this article focuses on modern digital electronic computers and their design";
string input = @"Computer once meant a person who did computations, but now the term almost universally refers to automated electronic machinery. The first section of this article focuses on modern digital electronic computers and their design";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}