re = /The (?:first|second) section of this article focuses on modern digital electronic computers and their design/m
str = 'Computer once meant a person who did computations, but now the term almost universally refers to automated electronic machinery. The first section of this article focuses on modern digital electronic computers and their design'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end