package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)The (?:first|second) section of this article focuses on modern digital electronic computers and their design`)
var str = `Computer once meant a person who did computations, but now the term almost universally refers to automated electronic machinery. The first section of this article focuses on modern digital electronic computers and their design`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}