package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]|[0-1][0-2])\:?([0-5][0-9])? ([A|P]M) to ([0-9]|[0-1][0-2])\:?([0-5][0-9])? ([A|P]M)`)
var str = `9:59 AM to 5:59 PM
9 AM to 5 PM
9:00 PM to 5:00 AM
12 PM to 12 AM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}