$re = '/([0-9]|[0-1][0-2])\:?([0-5][0-9])? ([A|P]M) to ([0-9]|[0-1][0-2])\:?([0-5][0-9])? ([A|P]M)/m';
$str = '9:59 AM to 5:59 PM
9 AM to 5 PM
9:00 PM to 5:00 AM
12 PM to 12 AM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);