import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]|[0-1][0-2])\\:?([0-5][0-9])? ([A|P]M) to ([0-9]|[0-1][0-2])\\:?([0-5][0-9])? ([A|P]M)";
final String string = "9:59 AM to 5:59 PM\n"
+ "9 AM to 5 PM\n"
+ "9:00 PM to 5:00 AM\n"
+ "12 PM to 12 AM";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}