# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\|Transition Reason:(?<Transiction_Reason>[^\|]*)\|"
test_str = ("Data1: |Transitioned to:Team1|Transition Reason:Out of Scope|handledbySomeone3|\n"
"Data2: |Transitioned to:Team2|Transition Reason:Invalid Description|handledbySomeone2|\n"
"Data3: |Transitioned to:Team3|Transition Reason:Incomplete Details|handledbySomeone1|")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.