import Foundation
let pattern = #"\|Transition Reason:(?<Transiction_Reason>[^\|]*)\|"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Data1: |Transitioned to:Team1|Transition Reason:Out of Scope|handledbySomeone3|
Data2: |Transitioned to:Team2|Transition Reason:Invalid Description|handledbySomeone2|
Data3: |Transitioned to:Team3|Transition Reason:Incomplete Details|handledbySomeone1|
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)