package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mix)(?:https?://|www\d{0,3}[.]|[a-z0-9.\-]+[.][a-z]{2,4}/)
([^\s()<>]+|\(([^\s()<>]+|(\([^\s()<>]+\)))*\))[^\s()<>]*
[^\s`!()\[\]{};:\'".,<>?«»“”‘’]`)
var str = `https://test.com/test!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}