re = /(?:https?:\/\/|www\d{0,3}[.]|[a-z0-9.\-]+[.][a-z]{2,4}\/)
([^\s()<>]+|\(([^\s()<>]+|(\([^\s()<>]+\)))*\))[^\s()<>]*
[^\s`!()\[\]{};:\'".,<>?«»“”‘’]/mix
str = 'https://test.com/test!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end