$re = '/(?:https?://|www\d{0,3}[.]|[a-z0-9.\-]+[.][a-z]{2,4}/)
([^\s()<>]+|\(([^\s()<>]+|(\([^\s()<>]+\)))*\))[^\s()<>]*
[^\s`!()\[\]{};:\'".,<>?«»“”‘’]/mix';
$str = 'https://test.com/test!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);