import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b&\\b(?!\\w+;)";
final String string = "a<a\n"
+ "a>a\n"
+ "a'a\n"
+ "a"e;a\n"
+ "a&a\n"
+ "johnson&johnson\n"
+ "J&J\n"
+ "R&D\n"
+ "P&AB\n"
+ "M&ABC\n"
+ "O&ABCD\n"
+ "B&SS-IHC\n"
+ "S&B\n"
+ "GC&E\n"
+ "M&G\n"
+ "P&D";
final String subst = "&";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}