import Foundation
let pattern = #"\b&\b(?!\w+;)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a<a
a>a
a'a
a"e;a
a&a
johnson&johnson
J&J
R&D
P&AB
M&ABC
O&ABCD
B&SS-IHC
S&B
GC&E
M&G
P&D
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"&"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)