import re
regex = re.compile(r"\{\s\d(?:[\d]*\.\d+|[\d]*)\}")
test_str = ("{ 16812},\n"
"{ 16812},\n"
"{ 16813},\n"
"{ 16819},\n"
"{ 16812},\n"
"{value 16812},\n"
"{value 16812]},")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")