# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\A(?:.*\R){15}\K\X+//gm;t' <<< "1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20"