use strict;
my $str = '1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20';
my $regex = qr/\A(?:.*\R){15}\K\X+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";