#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?>(screen_name:\s+\S)|\G(?!^))\S(?=\S)"
Local $sString = "screen_name: jack" & @CRLF & _
"screen_name: mack" & @CRLF & _
""
Local $sSubst = "\1*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)