$re = '/(?>(screen_name:\s+\S)|\G(?!^))\S(?=\S)/';
$str = 'screen_name: jack
screen_name: mack
';
$subst = "\1*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;