re = /(?>(screen_name:\s+\S)|\G(?!^))\S(?=\S)/
str = 'screen_name: jack
screen_name: mack
'
subst = '\\1*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result