#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\s)(\d+)\s(st(u?)k?)s?|(p((ie)?ce(s?)))"
Local $sString = "apple 10m" & @CRLF & _
"10mm" & @CRLF & _
"11ml" & @CRLF & _
"11kg" & @CRLF & _
"12g" & @CRLF & _
"13gr" & @CRLF & _
"14m3" & @CRLF & _
"15m2" & @CRLF & _
"" & @CRLF & _
"apple 10 stuks " & @CRLF & _
"10 pieces" & @CRLF & _
"11 pces" & @CRLF & _
"11 pce" & @CRLF & _
"12 stk" & @CRLF & _
"13 stuks" & @CRLF & _
"14m3" & @CRLF & _
"15m2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")