using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s)(\d+)\s(st(u?)k?)s?|(p((ie)?ce(s?)))";
string input = @"apple 10m
10mm
11ml
11kg
12g
13gr
14m3
15m2
apple 10 stuks
10 pieces
11 pces
11 pce
12 stk
13 stuks
14m3
15m2";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}