using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bkey=""(abcd(?:-\w+)*[^-][^e][^d]\w)""";
string input = @"object{one=""ab-vwxc"",two=""value1"",key=""abcd-st-ed-qrew-btn-qa"",four=""obsolete Values""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}