package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bkey="(abcd(?:-\w+)*[^-][^e][^d]\w)"`)
var str = `object{one="ab-vwxc",two="value1",key="abcd-st-ed-qrew-btn-qa",four="obsolete Values"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}