re = /\bkey="(abcd(?:-\w+)*[^-][^e][^d]\w)"/m
str = 'object{one="ab-vwxc",two="value1",key="abcd-st-ed-qrew-btn-qa",four="obsolete Values"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end