#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^ktm-(?:.*-abcd)(?:-(?:e-|[^e]|e[^d].)*)(?:-[a-z]+).*|^abcd(?:-(?:e-|[^e]|e[^d].)*)(?:-[a-z]+).*)"
Local $sString = "ktm-ewe-abcd-st-ed-qrew" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")