package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^ktm-(?:.*-abcd)(?:-(?:e-|[^e]|e[^d].)*)(?:-[a-z]+).*|^abcd(?:-(?:e-|[^e]|e[^d].)*)(?:-[a-z]+).*)`)
var str = `ktm-ewe-abcd-st-ed-qrew
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}