import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[^\\s]+)?(соус(?:[^\\s,\\.:;!?]+)?)(\\s)?";
final String string = "Соус\n"
+ "соусом\n"
+ " соус. под соусом; на соусе нет соуса!\n"
+ "Ошибка: подсоусом";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}