use strict;
my $str = 'Соус
соусом
соус. под соусом; на соусе нет соуса!
Ошибка: подсоусом';
my $regex = qr/(?:[^\s]+)?(соус(?:[^\s,\.:;!?]+)?)(\s)?/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";