const regex = /(?:[^\s]+)?(соус(?:[^\s,\.:;!?]+)?)(\s)?/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[^\\s]+)?(соус(?:[^\\s,\\.:;!?]+)?)(\\s)?', 'ig')
const str = `Соус
соусом
соус. под соусом; на соусе нет соуса!
Ошибка: подсоусом`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);