const regex = new RegExp('\\s((\\s)(\\s+)?)?', 'gm')
const str = `'A l a m a k o t a'`;
const subst = `\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);