use strict;
my $str = '\'A l a m a k o t a\'';
my $regex = qr/\s((\s)(\s+)?)?/mp;
my $subst = '\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";