$re = '/\s((\s)(\s+)?)?/m';
$str = '\'A l a m a k o t a\'';
$subst = "\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;