using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w+(?:,[\w]+)* as [^,\n]+(?:[\w]+(?:,[\w]+)* as [^,\n]+)*$";
string input = @"user_id as User Id,first_name as First Name,last_name as Last Name,email_address as Email,alias_address as Alternative Emails,telephone_number as Telephone Number,Country as country ID,state as state Name,city as city,department as working department,bankaccount as bank account,last_login_date as Last login Date (UTC),last_aaded_date as Last Added Date (UTC),branch_id as branch ID,branch_name as Branch Name";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}