const regex = /^\w+(?:,[\w]+)* as [^,\n]+(?:[\w]+(?:,[\w]+)* as [^,\n]+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w+(?:,[\\w]+)* as [^,\\n]+(?:[\\w]+(?:,[\\w]+)* as [^,\\n]+)*$', 'gm')
const str = `user_id as User Id,first_name as First Name,last_name as Last Name,email_address as Email,alias_address as Alternative Emails,telephone_number as Telephone Number,Country as country ID,state as state Name,city as city,department as working department,bankaccount as bank account,last_login_date as Last login Date (UTC),last_aaded_date as Last Added Date (UTC),branch_id as branch ID,branch_name as Branch Name`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}