package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?(GET|POST).*?([\/\w]+)`)
var str = `100.100.100.1 - - [11/Oct/2019:17:49:47 +0000] "GET /someroute/rest/endpoint?param=2019-09-25 HTTP/1.1"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}