re = /^.*?(GET|POST).*?([\/\w]+)/m
str = '100.100.100.1 - - [11/Oct/2019:17:49:47 +0000] "GET /someroute/rest/endpoint?param=2019-09-25 HTTP/1.1"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end