use strict;
my $str = '100.100.100.1 - - [11/Oct/2019:17:49:47 +0000] "GET /someroute/rest/endpoint?param=2019-09-25 HTTP/1.1"';
my $regex = qr/^.*?(GET|POST).*?([\/\w]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}