package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<type>\w+)\/(?<subtype>[\w\.-]+)(?:\+(?<suffix>[\w\.-]+))*(?:\s*;\s*(?<key>[^=]+?)(?:=""?(?<value>[\S\.-]+?)""?)?)*$`)
var str = `application/vnd.openxmlformats-officedocument.wordprocessingml.document;src=`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}