// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?<type>\w+)\/(?<subtype>[\w\.-]+)(?:\+(?<suffix>[\w\.-]+))*(?:\s*;\s*(?<key>[^=]+?)(?:=""?(?<value>[\S\.-]+?)""?)?)*$"#).unwrap();
let string = "application/vnd.openxmlformats-officedocument.wordprocessingml.document;src=";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}