re = /(?<type>\w+)\/(?<subtype>[\w\.-]+)(?:\+(?<suffix>[\w\.-]+))*(?:\s*;\s*(?<key>[^=]+?)(?:=""?(?<value>[\S\.-]+?)""?)?)*$/
str = 'application/vnd.openxmlformats-officedocument.wordprocessingml.document;src='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end