const regex = new RegExp('{{%(cellbg\\s*.+?)\\s*}}', 'gmi')
const str = `sometext.here{{%cellbg key.value }}some.other.text.i.don't.care.about`;
const subst = `{% \1 %}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);