#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\"type\": \"BinaryExpression\",\s*(\".+\": +\"?.+\"?,?\s*)*(\".+\": \{\s*(\".+\": +\"?.+\"?,?\s*)+\},?\s*)+"
Local $sString = "{" & @CRLF & _
" "type": "ExpressionStatement"," & @CRLF & _
" "expression": {" & @CRLF & _
" "type": "LogicalExpression"," & @CRLF & _
" "operator": "||"," & @CRLF & _
" "left": {" & @CRLF & _
" "type": "LogicalExpression"," & @CRLF & _
" "operator": "||"," & @CRLF & _
" "left": {" & @CRLF & _
" "type": "LogicalExpression"," & @CRLF & _
" "operator": "&&"," & @CRLF & _
" "left": {" & @CRLF & _
" "type": "BinaryExpression"," & @CRLF & _
" "operator": "=="," & @CRLF & _
" "left": {" & @CRLF & _
" "type": "Identifier"," & @CRLF & _
" "name": "column1"" & @CRLF & _
" }," & @CRLF & _
" "right": {" & @CRLF & _
" "type": "Li{t}eral"," & @CRLF & _
" "value": 1," & @CRLF & _
" "raw": "1"" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" "right": {" & @CRLF & _
" "type": "BinaryExpression"," & @CRLF & _
" "operator": "=="," & @CRLF & _
" "left": {" & @CRLF & _
" "type": "Literal"," & @CRLF & _
" "value": "column2"," & @CRLF & _
" "raw": "'column2'"" & @CRLF & _
" }," & @CRLF & _
" "right": {" & @CRLF & _
" "type": "Literal"," & @CRLF & _
" "value": "value"," & @CRLF & _
" "raw": "'value'"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" "right": {" & @CRLF & _
" "type": "BinaryExpression"," & @CRLF & _
" "operator": "=="," & @CRLF & _
" "left": {" & @CRLF & _
" "type": "Identifier"," & @CRLF & _
" "name": "year"" & @CRLF & _
" }," & @CRLF & _
" "right": {" & @CRLF & _
" "type": "Literal"," & @CRLF & _
" "value": 2006," & @CRLF & _
" "raw": "2006"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" "right": {" & @CRLF & _
" "type": "LogicalExpression"," & @CRLF & _
" "operator": "&{&"," & @CRLF & _
" "left": {" & @CRLF & _
" "type": "BinaryExpression"," & @CRLF & _
" "operator": "=="," & @CRLF & _
" "left": {" & @CRLF & _
" "type": "Literal"," & @CRLF & _
" "value": "column2"," & @CRLF & _
" "raw": "'column2'"" & @CRLF & _
" }," & @CRLF & _
" "right": {" & @CRLF & _
" "type": "Literal"," & @CRLF & _
" "value": "value1"," & @CRLF & _
" "raw": "'value1'"" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" "right": {" & @CRLF & _
" "type": "BinaryExpression"," & @CRLF & _
" "operator": "!="," & @CRLF & _
" "left": {" & @CRLF & _
" "type": "Literal"," & @CRLF & _
" "value": "column2"," & @CRLF & _
" "raw": "'column2'"" & @CRLF & _
" }," & @CRLF & _
" "right": {" & @CRLF & _
" "type": "Literal"," & @CRLF & _
" "value": "value2"," & @CRLF & _
" "raw": "'value2'"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")