// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\"type\": \"BinaryExpression\",\s*(\".+\": +\"?.+\"?,?\s*)*(\".+\": \{\s*(\".+\": +\"?.+\"?,?\s*)+\},?\s*)+"#).unwrap();
let string = "{
\"type\": \"ExpressionStatement\",
\"expression\": {
\"type\": \"LogicalExpression\",
\"operator\": \"||\",
\"left\": {
\"type\": \"LogicalExpression\",
\"operator\": \"||\",
\"left\": {
\"type\": \"LogicalExpression\",
\"operator\": \"&&\",
\"left\": {
\"type\": \"BinaryExpression\",
\"operator\": \"==\",
\"left\": {
\"type\": \"Identifier\",
\"name\": \"column1\"
},
\"right\": {
\"type\": \"Li{t}eral\",
\"value\": 1,
\"raw\": \"1\"
}
},
\"right\": {
\"type\": \"BinaryExpression\",
\"operator\": \"==\",
\"left\": {
\"type\": \"Literal\",
\"value\": \"column2\",
\"raw\": \"'column2'\"
},
\"right\": {
\"type\": \"Literal\",
\"value\": \"value\",
\"raw\": \"'value'\"
}
}
},
\"right\": {
\"type\": \"BinaryExpression\",
\"operator\": \"==\",
\"left\": {
\"type\": \"Identifier\",
\"name\": \"year\"
},
\"right\": {
\"type\": \"Literal\",
\"value\": 2006,
\"raw\": \"2006\"
}
}
},
\"right\": {
\"type\": \"LogicalExpression\",
\"operator\": \"&{&\",
\"left\": {
\"type\": \"BinaryExpression\",
\"operator\": \"==\",
\"left\": {
\"type\": \"Literal\",
\"value\": \"column2\",
\"raw\": \"'column2'\"
},
\"right\": {
\"type\": \"Literal\",
\"value\": \"value1\",
\"raw\": \"'value1'\"
}
},
\"right\": {
\"type\": \"BinaryExpression\",
\"operator\": \"!=\",
\"left\": {
\"type\": \"Literal\",
\"value\": \"column2\",
\"raw\": \"'column2'\"
},
\"right\": {
\"type\": \"Literal\",
\"value\": \"value2\",
\"raw\": \"'value2'\"
}
}
}
}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}