using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""type\"": \""BinaryExpression\"",\s*(\"".+\"": +\""?.+\""?,?\s*)*(\"".+\"": \{\s*(\"".+\"": +\""?.+\""?,?\s*)+\},?\s*)+";
string input = @"{
""type"": ""ExpressionStatement"",
""expression"": {
""type"": ""LogicalExpression"",
""operator"": ""||"",
""left"": {
""type"": ""LogicalExpression"",
""operator"": ""||"",
""left"": {
""type"": ""LogicalExpression"",
""operator"": ""&&"",
""left"": {
""type"": ""BinaryExpression"",
""operator"": ""=="",
""left"": {
""type"": ""Identifier"",
""name"": ""column1""
},
""right"": {
""type"": ""Li{t}eral"",
""value"": 1,
""raw"": ""1""
}
},
""right"": {
""type"": ""BinaryExpression"",
""operator"": ""=="",
""left"": {
""type"": ""Literal"",
""value"": ""column2"",
""raw"": ""'column2'""
},
""right"": {
""type"": ""Literal"",
""value"": ""value"",
""raw"": ""'value'""
}
}
},
""right"": {
""type"": ""BinaryExpression"",
""operator"": ""=="",
""left"": {
""type"": ""Identifier"",
""name"": ""year""
},
""right"": {
""type"": ""Literal"",
""value"": 2006,
""raw"": ""2006""
}
}
},
""right"": {
""type"": ""LogicalExpression"",
""operator"": ""&{&"",
""left"": {
""type"": ""BinaryExpression"",
""operator"": ""=="",
""left"": {
""type"": ""Literal"",
""value"": ""column2"",
""raw"": ""'column2'""
},
""right"": {
""type"": ""Literal"",
""value"": ""value1"",
""raw"": ""'value1'""
}
},
""right"": {
""type"": ""BinaryExpression"",
""operator"": ""!="",
""left"": {
""type"": ""Literal"",
""value"": ""column2"",
""raw"": ""'column2'""
},
""right"": {
""type"": ""Literal"",
""value"": ""value2"",
""raw"": ""'value2'""
}
}
}
}
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}