import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "## \\(#.*?\\)";
final String string = "## (#compact)`_.compact(array)`\n\n"
+ "## (#concat)`_.concat(array, [values])`";
final String subst = "## \\{#.*?\\}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}