import re
regex = re.compile(r"## \(#.*?\)", flags=re.MULTILINE)
test_str = ("## (#compact)`_.compact(array)`\n\n"
"## (#concat)`_.concat(array, [values])`")
subst = "## \\{#.*?\\}"
result = regex.sub(subst, test_str)
if result:
print(result)