using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\(first\)|\[first]|{first})(*SKIP)(*FAIL)|\bfirst\b";
string input = @"This is a (first) test with the first hit
This is a first test
This is a (first] test with the first hit";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}